AfterDawn: Tech news

PSP v3.03 downgrader out

Written by Matti Vähäkainu (Google+) @ 29 Jan 2007 4:18 User comments (60)

PSP v3.03 downgrader out Noobz has released a new downgrader for PSP, this time v3.03 PSPs can be downgraded to v1.5. The downgrader doesn't work on other firmware versions, but if one has v2.81 - v3.02 firmware, he can upgrade it to v3.03 and then use the downgrader. Ultimately this means that all the PSPs out there can run homebrew and according to Noobz the downgrader is easy to use. Here are the details:
Some ground-rules:

* This downgrader is for v3.03 firmware only. But if you have v2.81 - v3.02, no problem - you can just upgrade to v3.03 to use the downgrader.
* You need a copy of the unpatched GTA:Liberty City Stories UMD. No ISOs, no patched UMDs, not Vice City Stories. See here for some info on how to check if your version is patched. The most reliable way : the unpatched disks have the v2.0 firmware update on them.
* This downgrader is intended to enable homebrew. Homebrew is NOT the same as piracy. Don't be a thieving loser - buy the games you play.
* The downgrader will work on all current PSP hardware (TA-079 - TA-086). Patching of TA-082+ is automatic in the downgrader.
* You downgrade at your own risk. There is always a chance of bricking, although we have done everything we can think of to make this process safe.

Full instructions for downgrading are included in the Downgrader_HOWTO.txt file in the ZIP file. Read them carefully! You will need:

* The 3.03 downgrader package
* Official v1.50 Firmware Update EBOOT
* Official v3.03 Firmware Update EBOOT (only if your PSP is not 3.03 already)

Warning: After downgrading from 3.03 to 1.5, there are some remnants of 3.03 left in flash. If you later try to re-upgrade to 3.03 and repeat the downgrade, things will break. At some later point, we will work on a cleaner that will remove these extra files. Until then, enjoy! (Don't worry, upgrading to 3.03 OE firmwares still works fine).


Source:
Noobz

Previous Next  

60 user comments

129.1.2007 4:36

I was wondering if there was a software/firmware patch that will allow the PSP to be louder. My games are plenty loud but the movies and TV shows you can barely hear.I even use a pair of noise canceling head phones and still barely hear.

229.1.2007 4:57
cossitt
Inactive

I don't no about the software/firmware patch thing but this might help-
you can go to settings/video settings/UMD Video volume, and then you can make videos quieter or louder

*and whats with the name of the thread having nothing to do with your question??

This message has been edited since its posting. Latest edit was made on 29 Jan 2007 @ 4:58

329.1.2007 9:17

I think this is a great app for the psp,but the only problem is where do you find GTA Liberty City Stories with the 2.00 firmware.I think the best thing to do is wait for a downgrader that doesn't use GTA Liberty City Stories,as I can't find it without paying a bunch of money for it.I heard a new psp modchip is coming out though from psp-devolution that will replace the undiluted platinum modchips.It is said that it will work on all versions of psp,but I can't confirm that it is real or not.

429.1.2007 9:30

hi great that someone has created a downgrader for 3.03 but do you have to use GTA:LCS or eney game with 2.00 firmware?

529.1.2007 9:35

because i have madden 06 witch has version 2.00

629.1.2007 10:57

LOL no Madden will not work, only GTA will.

729.1.2007 13:47
angeshman
Inactive

hi, im new to this site but i did download the psp v3.03 downgrader to downgrade my psp from 3.3 to 1.5.The problem is it does not work. i am sure i followed the dirrection as asked. with the gta lcs v2.0 umd and loadind it and every thing, but nothing happpenz!!! i would have been glad to see my psp downgraded. nothing!! doez the downgrade work? if so help pleez!!

829.1.2007 14:01
angeshman
Inactive

My God!! why wont the downgrader work. Someone tell meh, am i stuck with v3.03 4 ever

929.1.2007 17:42

Why can't the games be upgraded instead?

1029.1.2007 17:47

^^^^ what? Do explain what you mean, I for one have no idea.



1129.1.2007 18:39

I think ThePezman is talking about the modules for psp games being upgraded for higher firmware usage.I think what he is trying to say is port games to a higher firmware.I don't think it is possible,cause only a Sony verified developer has the source codes and tools to do that.Sony will not release their source codes for games to the public and they don't release their libraries either.They protect themselves and game developers by keeping this away from the public for piracy matters.The downgraders,custom firmwares,devhook etc... used are coded by people that are not in any way affiliated with Sony.I have been looking at the latest modchip that is suppose to come out from psp-devolution and it supports ta-082 up to ta-086 model psp systems.The chip located on the mod is an Actel ProASIC3,more information can be found on this site about the Actel ProASIC3 chip they are using for the mod http://www.mouser.com/search/ProductDetail.aspx?R=A3P060-VQG100virtualkey61820000virtualkey892-A3P060-VQG100 .The site to the actual modchip is located here http://www.psp-devolution.com/ and a more indepth description on its capabilities.If you get a modchip you can downgrade or upgrade whatever firmware you want on your psp as many times as you like.Also it can prevent your psp from bricking.I just wanted to say a modchip is the ultimate solution for homebrew for any type of game system.

1229.1.2007 18:47

Well the homebrew games have to be coded in order to play on any version of the PSP, so obviously the homebrew developers must know how to emulate the PSP at a certain level of firmware. What's to prevent them from doing what they did the first time to this latest version?

1329.1.2007 18:53

L-Burna that was interesting to read, but in all honesty I do not think that he meant anything close to the response you provided. His response was extremely abstract, just my opinion though.

But i do thank you for the read, that was one of the most well thought out posts i have read in a looooooong while :)

I for one do not think a chip is a worthwhile investment. I do know that the UP chip does not support ta-082 or above, but look what happened in the past. If I remember correctly, the 2.5-2.6 downgrader was released the same day the chip became a reality, and like this new downgrader, all that was required was an unpatched GTA umd. Yeah if you are a noob and do not want to risk it, i agree, go with the new modchip. For the vast amount of users that take a moment or two to read, I really do think that this new downgrader is all they need. Or, just wait a month or so (speculation of course) until the ability to downgrade without the use of GTA becomes available. Any way you look at it, Sony lost the battle :D


This message has been edited since its posting. Latest edit was made on 29 Jan 2007 @ 18:55


1429.1.2007 22:10
tabletpc
Inactive

this is not a big deal because you need the 3.03 firmware and a umd disk to boot the downgrader second several psp's that have hit the market not only do not support the version 1.5 firmware but if you downgrade to the version 1.5 firmware you can kiss your psp goodbye because it wont boot

1529.1.2007 22:21

Originally posted by tabletpc:
this is not a big deal because you need the 3.03 firmware and a umd disk to boot the downgrader

second several psp's that have hit the market not only do not support the version 1.5 firmware but if you downgrade to the version 1.5 firmware you can kiss your psp goodbye

because it wont boot
That made 0 sense.....if you have a 2.80 or above you can upgrade to 3.03 and then use this downgrader.....in the future please do know what you are talking about before you post! BTW, no matter what your mobo is, you can use this downgrader, so again your wrong!

Please people, before you post total nonsense, do your research before you post total BS! Honeslty information like the poster above is why the psp forum is so messed up!


1630.1.2007 2:14
angeshman
Inactive

Did anyone with the newly up dated 3.3 version try the downgrader? did it work? cause i cant get mine to work.

1730.1.2007 2:22

does n e 1 know where 2 download Official v1.50 Firmware Update EBOOT plz and thanx

1830.1.2007 2:27

Thanks svtstang for taking the time to read and comment on what I said earlier.I agree with what you said on the 3.03 downgrader.It will eventually come out with no need of the GTA Liberty City Stories unpatched version.The UP chip never actually became a success though,because it barely has any updates for it and to be honest wasn't used to its full potential.If this modchip becomes real it might have better support than the UP modchip and have more possibilities.The modchip could in fact be a waste of time also as you mentioned.I just can't really disregard the modchip at the moment though without seeing what it can actually do first.You make a very good point,but until more information comes out for the modchip I will keep it in mind.

1930.1.2007 2:42
angeshman
Inactive

hey can someone show me how to find the ROOT OF MY MEMORY STICK. i understand it should look like. x:/. but how to find it. thanx

2030.1.2007 2:47
angeshman
Inactive

YOKOROB u should be able to find an 1.5 update in dis site or QJ.NET or just use google and type- download psp 1.50 update.

2130.1.2007 3:28
angeshman
Inactive

can someone tell me what do they mean by the root of the memory stick. is it game? if not how do i find it.

2230.1.2007 3:39

well im not sure what is said above is true but i bought my psp as a 2.71 and made the stupid mistake of upgrading to 3.03.

But i just last night bought a used copy of GTA for 17 bucks. Used the downgrader wich took 15 minuts and then upgraded to 3.03OE-C. Now i can play ALL my roms again. And that makes my psp usefull again. Thanks for the downgrader guys!

2330.1.2007 11:35

thanks angeshman i got everything i need now but step 6-Copy the contents of the folder MS_ROOT from the 3.03 downgrader ZIP to
the memory stick what folder do i put it into

2430.1.2007 13:28

No prob L-Burna, I enjoy meaningful posts, especially lately when the majority of posts I see are giberish LOL! The UP was a great concept, just that is was a last resort for those that had no means to downgrade the psp at the time. The chip had very few features, partially because the psp had relatively few features. Now that ps1 emulation is available, the possibilites for the newly announced chip may be worthwhile, especially if Sony incorporates some more features in the vein of ps1 emulation.

@yokorob

Stick the MS_Root folder in the root of your mem stick, aka the main folder when you connect your psp to your comp via usb. The folders contained in the MS_Root will be placed in their respective locations automatically.



2530.1.2007 14:51

thanx alot man you really helped me out.owe you 1

2630.1.2007 18:50

No problem, glad I could help :)

2731.1.2007 7:21

Hey. I'v downloaded all the neccessary files to downgrade v3.03 but was wondering if the folder named "SRS" has anything to do with the downgrade as it is alongside the MS_ROOT folder but there is no reference about what to do with this folder?!?!


-@m0 $4nGh@-

281.2.2007 11:25

okay..i might be dumb at all this lol.or i just did it wrong..but come someone add me on their msn messenger and help me downgrade my psp?... first..my psp is a 3.03 ..and yeahi have the gta game with the 2.00 update.. and i'm pretty sure i downloaded the right thing to downgrade with. i just need steps on what to do now..help? msn addy - dantedelacroix@hotmail.com thanks

291.2.2007 14:00

Not to sound like an ass, but the readme has more then adequate instructions on how to downgrade your psp...all you need are the 2 downgrade files (actual downgrader and HEN), and a 1.5/3.03 update eboot (only 1.5 if you already have a 3.03). Just follow the readme, you will be fine.

This message has been edited since its posting. Latest edit was made on 01 Feb 2007 @ 14:01


301.2.2007 21:24

i know i know ..but i read the read me thing.and i was pretty sure i followed all the instructions..but when i loaded gta.the screen didn't do what it was supposed to.. so can someone help?..msn addy dantedelacroix@hotmail.com ..ps ..has anyone here successfully downgraded their psp?

312.2.2007 1:56

hells yeah we have sucessfully downgraded our v3.03 psp's.
dont you think we would have a whole shit load of threads calling it bullshit if it didd'nt work? i mean common!!
as for your walkthrough.. i wont sit there messeging you back and forth all night to try to convince you all is well so here is a step by step from qj.net.
Instructions
------------
Here are the steps to downgrade any 3.03 PSP to 1.50:

1 - If you have a 3.03 PSP skip to step 6

2 - Download 3.03 update from here:
http://dl.qj.net/PSP-Firmware-3.03-PSP/pg/12/fid/11844/catid/163

3 - Unzip and place the file in :/PSP/GAME/UPDATE

4 - On the PSP, run the 3.03 update from the memory stick under the Game menu.

5 - Delete :/PSP/GAME/UPDATE

6 - Copy the contents of the folder MS_ROOT from the 3.03 downgrader ZIP to
the memory stick

7 - Unzip the 1.50 update to a temporary folder. Rename the EBOOT.PBP to
UPDATE.PBP and copy it to :/PSP/GAME/UPDATE/ . DO NOT
OVERWRITE PSP/GAME/UPDATE/EBOOT.PBP!

8 - Load GTA LCS

9 - It should get to loading savegame, then the screen will clear to black
and fill with a light blue colour, then the PSP will reset itself (if
this does not happen see section below)

10 - Check that HEN is running by going to system settings, then to
"System Information" and it should show up as system version
303 HEN

11 - If it is showing up as HEN then go to the memory stick and
run the x.yz update

12 - If you have an unpatched TA-082 or higher motherboard, you will be
prompted to allow the downgrader to patch your motherboard so it
can be safely downgraded. The downgrader will not let you proceed
without patching, if your motherboard requires it.

13 - Before the downgrader does anything to your PSP it will ask
for you to agree to what it is doing, if you no longer want to
continue press the Right Shoulder Button (R-TRIGGER).

14 - Once you have agreed to start the downgrade do not unplug the
PSP, or try and restart it

15 - Once finished the PSP will ask you to press X, and reset itself

16 - If it comes up saying that the settings are corrupt, press x
to continue, this will mean you will need to re-enter the
settings for network connections into your PSP, otherwise go to
step 18

17 - Load the included NetConfigBackup application in your PSP, and select to
restore, this will take the backup that was done of the network config
that was done automatically during the downgrade.

18 - All done now :-) Hopefully you now have a 1.50 PSP. Enjoy it responsibly.

---IMPORTANT---
dont try to reupgrade to 3.03(official sony fw, custom 3.03oe's are ok) you will brick!!!

if that dont do it for ya, i reccomend just sticking with what you got cuz nothing is gonna make you feel better bout flashing till you grow a sack.

on a side note, you can just load up 3.03 hen with gta:lcs and play homebrew with that. just note it is only hen till you fully turn off your psp.

good luck and god speed little noob!! :)




psp life:1.5>2.0>2.8>3.03>1.5>3.03OE-C
this is a very entertaining thread, check it out!!:)
http://www.forums.afterdawn.comthread_view.cfm/386996

322.2.2007 4:34

On no. 9 you said It should get to loading savegame, then the screen will clear to black and fill with a light blue colour, then the PSP will reset itself. Ya that happens for me but when it does happen it goes straight back to the main page. What are my supposed to do after that, the update.pbp file says that it is corrupt and that doesn't work. You also said to go into system information and see if it says Version 303 HEN. Well mine says version 3.03 whats with that, does that mean that it won't work I did everything you said to do and still can't find the problem please tell how to fix this problem, if there is a way.

332.2.2007 6:00

well i would suggest you redownload the downgrade files for a reputable site like qj.net. also you will want to check that the gta:lcs umd you have is not patched(usually can tell by the update on the disc, 2.0=unpatched 2.6=patched) if your umd is the patched version then it wont work. however, the x.yz update should display just fine in 3.03(sony version) so i think you DLed a shotty version. i suggest searching qj.net, thier files are all good. good luck

343.2.2007 5:25

Ya mine is the Unpatched GTA LCS game firmware 2.0 update, what happens with me is when I load GTA LCS eveything goes fine it resets itself like you said. Then I go into system information and it says System SOftware Version 3.03 not 303 HEN which is supposed to happen why is this. I got my psp the week it came out aswell as the game so there should'nt be a problem I did everyhing as ye said. Ye also said if GTA LCS doesn't reset itself copy the contents from the MS_ROOT folder SAVEGAMEDATA to the SAVEGAMEDATA in the psp. Thats how it resets for me as ye said it would, should it still work if I do that? Please help me as I've tried everything and still the UPDATE.PBP still comes up as corrupt.

353.2.2007 6:38
F_loug
Inactive

HEY EVERY TIME I TRY TO PUT THE PSP UPGRADER 3.03 I GET AN ERROR THAT I PUT IT IN THE WRONG PLCAE AND WHEN I TRY TO UPDATE IT ON MY PSP IT GOES "the game could not be started (80020148) HELLPPP PLZ ITS ANNOYING

364.2.2007 22:56

Hey, I agree with the noobees out there. The 3.03 downgrader is not quite 100% clear. I had the same problems as a couple of the earlier posts. The how to says : "Unzip the 1.50 update to a temporary folder. Rename the EBOOT.PBP to UPDATE.PBP" but I found this did not work. But it worked if I just renamed the file to "UPDATE" without the ".PBP" extension. I hope this helps some of the guys just starting out like me.

375.2.2007 11:53
humzaiq
Inactive

i got hit by lightning for spamming this fine site!!! edited by ddp

This message has been edited since its posting. Latest edit was made on 05 Feb 2007 @ 13:03

385.2.2007 15:02
Coke_Kid
Inactive

where do u get those sgn things that are always at the bottom of ur comments

395.2.2007 15:03
Coke_Kid
Inactive

(*)sign(*)

405.2.2007 15:41
Coke_Kid
Inactive

yay

415.2.2007 15:46
Coke_Kid
Inactive

sry nvm

426.2.2007 1:40
Xenores
Inactive

Sweet. I might just upgrade to 3.03 now since the downgrader & Hen are out now on that firmware.

437.2.2007 23:53

does any1 know if there is any way i can downgrade my psp with liberty city stories even though it has a 2.60 upgrade on it?

4412.2.2007 13:05

Does this method work with all psp motherboards??
And how can you identify if the gta lcs UMD has a ver 2.0 or is unpatched??
Thanks for your help

4512.2.2007 15:30

yes and if the update on the gta:lcs umd is 2.0 its probably unpatched, if its above 2.0, its patched.
hope that helps.
btw the downgrader will automatically patch your motherboard if it needs it, it will prompt you before it patches it, you dont have to anything other than what the read me tells you to, it pretty much is automatic.

4612.2.2007 15:40

my last question is that if i buy a new gta lcs i wont be unpatched or i wont has any way of knowing if it has version 2.0 or not.

4712.2.2007 17:12
attias6
Inactive

For those who say that the 3.03-1.50 downgrader doesn't work,

I was stuck on 2.81 for 3 months and I had nothing to do but, as a gift, I got Grand Theft Auto: Liberty City Stories so I used for the downgrader and it worked! I upgraded from 2.81 to 3.03 and then downgraded to 1.50! So I'll explain the process:

You need:

1) A 1.50 EBOOT.PBP file from Sony (a website is given within the README.txt).
2) a 3.03 EBOOT.PBP file from Sony (a website is given within the README.txt).
3) Any Grand Theft Auto: Liberty City Stories (North America).

Instructions:

1) Update to 3.03 by putting the EBOOT.PBP (the 3.03 one) in the UPDATE folder within the GAME folder in the PSP folder (PSP>GAME>UPDATE)

2) Load it from your PSP in the Game menu, in the memory stick and update.

3) Once you've updated, delete the EBOOT.PBP from the UPDATE folder.

4) Copy the contents of MS_ROOT to the root of your memory stick.

5) Rename the EBOOT.PBP (the 1.50 one) to UPDATE.PBP (do not overwrite the EBOOT.PBP that will already be in the UPDATE file).

6) Load Grand Theft Auto: Liberty City Stories. When it loads, a light blue screen will appear and the PSP will reset itself.

7) Open your PSP, go to Settings, System Setting and in System Information, it should say 3.03 HEN.

8) Go to the Game menu in your memory stick and load the x.yz program.

9) It will ask you to press X if you want to downgrade and if you want to cancel, press R.

10) Wait patiently until the PSP will reset itself and hopefully, you will be in 1.50!

Aviv

4812.2.2007 17:16
attias6
Inactive

Download the downgrader from www.noobz.eu/download.html

4912.2.2007 17:43

does any GTA LCS work in north america
if not
how would you know if the game is unpatched or has ver 2.0 if it is packed since you cant open the case before buying it.

501.3.2007 3:55
Coke_Kid
Inactive

all i need is GTA :(

[url=http://nexgenwars.com/][img]



5116.3.2007 19:12

hey, i need some help hear.. umm i have no UPDATE file in my memory card. i go to PSP then GAME then no UPDATE file.

i got a v2.81 this is the 1st step to go to 3.03. i got the GTA with 2.00 update


email. superman_10000@hotmail.com. ill be on there 2. please someone help! lol i just got a 4g stick i gotta use! lol

5217.3.2007 8:07

please someone help

5325.3.2007 12:51

" there are some remnants of 3.03 left in flash. If you later try to re-upgrade to 3.03 and repeat the downgrade, things will break. At some later point, we will work on a cleaner that will remove these extra files. Until then, enjoy! (Don't worry, upgrading to 3.03 OE firmwares still works fine). "

Does anyone know if this could affect the function of certain ISOs? I ask because I have two PSP's, on my old one I can use a backup of xmen w/ no issues but on the one I used the 3.03 downgrader on, the thing skips and stutters during the intro and during gameplay? Really strange. I know the ISO itself is fine because it works on the other PSP, I've tried formatting different memory sticks but it only happens on the 3.03 downgraded PSP.

Anyone have any ideas whats going on here? My homebrew and other backed up ISO's I have work fine. Ironically, the only reason I use the above ISO is because the UMD lags too much. scratching my head. . . .

5425.3.2007 12:58

nads, if you follow the step by step instructions posted here and in the readme, you will be fine. Just take time to read them, make sure you have the three needed files and you'll be straight. Its really not that hard bro.

552.4.2007 15:52

You need GTA: LCS with 2.00 upgrade! you guys are morons and should of searched google long ago! I bought Five different kinds of GTA and the ones with 2.00 updates worked ONLY! I will send you free betas of downgraders for 3.30 if you are nice;) I will even send it in a nice easy install program! it's a beta so BE CAREFUL IT MIGHT BRICK YOUR PSP IF YOU RE-UPDATE TO 3.03 AGAIN. YOU ALSO TAKE THE RISK OF BRICKING BY USING ANY DOWNGRADERS SO IT'S BY YOUR OWN RISK! Buttttttttttt, the people who made the downgraders made sure you had a small bricking chance

This message has been edited since its posting. Latest edit was made on 13 Apr 2007 @ 20:48

DO NOT COPY THIS (Ha they'll never figure out this one!)

563.4.2007 15:23

When i try to upgrade to 3.03, i put it on my psp and go to game, but it shows corrupted data. Can anyone help me?

575.4.2007 10:44

Email me at crazy_frengy@hotmail.com and I will give you full instructions, ok? I have hacked and fixed over 5 PSPs and I got them Custom Firmwares with Super Mario Brothers (hehehe! ;) anyway e-mail me and I will help you

This message has been edited since its posting. Latest edit was made on 05 Apr 2007 @ 10:47

DO NOT COPY THIS (Ha they'll never figure out this one!)

5826.5.2007 8:28

Originally posted by F_loug:
HEY EVERY TIME I TRY TO PUT THE PSP UPGRADER 3.03 I GET AN ERROR THAT I PUT IT IN THE WRONG PLCAE AND WHEN I TRY TO UPDATE IT ON MY PSP IT GOES "the game could not be started (80020148) HELLPPP PLZ ITS ANNOYING
I have the same problem. Ive been searching forum after forum and found that theres a few of us out there but no one seems to know whats cuasing our problem

593.10.2007 16:33

i downgraded my psp from 3.03 to the 1.5 with the easy downgrade software.worked great as far as i know.but my question is mostly because i don't understand why a few of my functions have stopped.i can't listen to music or look at photo.granted they are not the best features but i likes them.now i just want to know is now that i downgraded with this program is it possible to go back to a newer version of firmware,maybe i'm not looking at everything.but i would rather not be stuck in this situation but here is my bed and i gotta lye in it.

601.1.2008 13:46
aldercy
Inactive

I have just done 2 psp's with this and then upgraded em to 3.03 OE-C No Probs!
Once again a round of applause for the noobz team!
Can't wait for the flash0 cleaner though

aldercy
http://www.i'manidiot.com edited by ddp

This message has been edited since its posting. Latest edit was made on 01 Jan 2008 @ 13:49

Comments have been disabled for this article.

News archive