AfterDawn: Tech news

Sorry older devices, HTC's Sense 3.0 is picky

Written by Andre Yoskowitz (Google+) @ 14 Apr 2011 18:35 User comments (6)

Sorry older devices, HTC's Sense 3.0 is picky HTC has tweeted today that the upcoming Sense 3.0 UI overlay will not be headed to older HTC devices, and will just work on the EVO 3D, the Sensation and the Flyer tablet.
Said the company (Twitter):

Due to Sense's hardware requirements, only our newest devices (Flyer, EVO 3D, Sensation) will be able to support it.


From the response, it appears that devices with single-core processors under 1.5GHz will not be able to support the updated UI, as the new phones have dual-core processors and the tablet has a single-core 1.5GHz.

However, not all is lost, HTC says they are working "to incorporate other aspects" of Sense 3.0 to their upcoming updates for older devices.

Video of the Sensation:

Previous Next  

6 user comments

114.4.2011 19:26

this is a joke developers at xda could easily port it

214.4.2011 20:25

Hell, I'd be happy with a simple upgrade to Gingerbread on my EVO


Oh, Im sorry... Did the middle of my sentence interrupt the beginning of yours?

314.4.2011 21:58

Looks like I'll have to wait for my yearly upgrade and get a EVO 3D.

415.4.2011 12:48

This is why I have a phone that just calls and texts. I don't need to upgrade my several hundred dollar phone every year just to keep it sort of relevant.

515.4.2011 16:50

That sucks for people using older htc phones. I am planning on getting the sensation anyways so no worries :)

This message has been edited since its posting. Latest edit was made on 15 Apr 2011 @ 16:51

The average woman would rather have beauty than brains, because the average man can see better than he can think.
--quote by unknown

616.4.2011 5:09

sucks majorly, I have HTC desire HD. It's only 5 months old. Might fork out the cash and buy myself, something with a dual core tegra 2 chip in it.

Comments have been disabled for this article.

News archive